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User's Guide
SLEU106–November 2009

TVP5151 Evaluation Module

1 Description

The TVP5151EVM is a four-layer printed circuit board designed for evaluation of the TVP5151
PAL/NTSC/SECAM video decoder. A THS8200 triple DAC is included on the circuit board to convert the
ITU-R BT.656 YCbCr digital output from the TVP5151 to YPbPr component video. Two composite video
(CVBS) input connectors and one YPbPr component video output connector are provided on the board for
input and output connections. I2C communication with the EVM is provided by a host PC USB port and the
VCC (Video Control Center) software tool provided with the EVM. All required power for TVP5151EVM is
supplied by the USB port. This user's guide outlines the necessary hardware and software setup required
to provide full evaluation of the TVP5151.

1.1 Functional Overview

The TVP5151EVM uses a host PC USB port to emulate the I2C bus, providing communication with the
TVP5151 video decoder and the THS8200 encoder. The VCC application software provided on the
TVP5151EVM CR-ROM communicates with the devices via the PC USB port.

The analog video inputs supported by the TVP5151AEVM include two composite video inputs. In general,
the video decoder converts the analog video input signal into 8-bit ITU-R BT.656 YCbCr digital component
data. This data and the associated clock from the video decoder are sent to the THS8200 for conversion
to analog YPbPr component video.

To experiment with the programmable features of the TVP5151 video decoder and the THS8200, the USB
port of the TVP5151EVM is connected to the USB port of a PC. VCC, a Windows™ compatible
application, provides the user interface for performing register-level and high-level control of the TVP5151
video decoder and the THS8200 encoder DAC. A PAL or NTSC composite video source and a monitor
capable of displaying YPbPr component video are required for evaluation.
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2 Board-Level Description

Figure 1 illustrates the primary components on the TVP5151EVM.

Figure 1. TVP5151EVM Board Layout

2.1 Analog Video Inputs

Two RCA video connectors are provided for connecting NTSC or PAL composite video sources to the
TVP5151EVM. CH1 is connected to the AIP1A input of the TVP5151, while CH2 is connected to the
AIP1B input. Both video inputs pass through anti-alias filters, termination resistors, and AC coupling
capacitors prior to connecting to the TVP5151 input. CH1 is the default channel selected by the TVP5151
input MUX and EVM software and is the recommended input when connecting a single video source.
S-video can be supported by connecting the Y (luminance) input to CH1 and the C (chrominance) input to
CH2.

2.2 Analog Component Video Output

RCA connectors are provided for connecting the YPbPr component video output to a suitable monitor. The
component video outputs are driven by the THS8200 DAC through filters similar to those used for the
composite video inputs. The THS8200 output and filters are designed for a 75-Ω video load. When viewing
the outputs on an oscilloscope, the component video outputs must be properly terminated with 75 Ω for
correct output levels. Composite video out is not supported with the TVP5151EVM.
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2.3 USB Interface and Power

A USB cable must be connected between the host PC and TVP5151EVM. The USB interface cable
provides the I2C communication required to program the TVP5151 and THS8200 and also provides the
5-V power required for the TVP5151EVM. An optional power jack (J1) is provided on the board to allow
use of a separate power supply if desired. If a separate 5-V power supply is used, R1 and R2 must be
removed from the TVP5151EVM and D1 installed. The USB interface circuitry remains powered by the
USB interface, if this separate supply is used. Voltage regulators on the EVM are used to generate the
1.8-V and 3.3-V levels required for the components on the board. LEDS are included on the board to
indicate the presence of 5-V power and USB connectivity.

2.4 Board Jumpers

The TVP5151 provides support for either 1.8-V or 3.3-V I/O levels. The I/O levels used by the
TVP5151EVM can be selected by moving the 0-Ω SMT resistor at J2. The EVM is shipped from the
factory with 3.3-V I/O selected. The J2 setting affects all digital I/O levels on the TVP5151EVM, including
the TVP5151, THS8200, I2C, and RESET.

The J7 power-down jumper can be used to place the TVP5151 in a low-power state. In this power-down
state, the TVP5151 I2C is not functional. See Table 1 for a summary of jumper options.

Table 1. Jumper Settings

Jumper Function Default Setting CommentDesignator

Selects TVP5151, THS8200, and I2C I/O levels, 0-ΩJ2 1.8-V/3.3-V I/O select 3.3-V SMT

J6 TVP5151 I2CA select B8h TVP5151 I2C address, 0-Ω SMT

1-2, normalJ7 TVP5151 power down I2C disabled during power downoperation

J9 Reserved for test Installed Must be installed for USB I2C functionality

J10 Analog/digital GND connection Installed 0-Ω SMT

J11 Analog/digital GND connection Not installed Optional

2.5 Test Points

Test points are provided on the TVP5151EVM to assist in evaluation of the TVP5151. All TVP5151 digital
outputs are brought out to the P1 dual row header that can be used for testing and external connections.
See Table 2 and Figure 2 for available test points.

Table 2. Test Points

Test Point Function CommentDesignator

TP1 3.3 V Main 3.3-V supply for the board

TP2, TP19 DGND Digital ground

TP3 1.8 V Main 1.8-V supply for the board

TP5 AGND Analog ground

TP17 SDA I2C data

TP18 SCL I2C clock
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Figure 2. P1 Header Pinout

2.6 TVP5151 Crystal Requirements

The TVP5151EVM is shipped from the factory with a 5.0-mm x 3.2-mm 27-MHz crystal installed. An
additional footprint is also included on the PCB (see Figure 3) for evaluation of smaller 2.0-mm x 1.6-mm
crystals. This smaller crystal is a 4-pin device and must be oriented correctly on the EVM. C62 and C59
are load capacitors for the crystal and must be sized according to the specification of the crystal used. The
TVP5151EVM is shipped from the factory with 33-pF load capacitors installed in support of the crystal
used. The frequency stability of the crystal used must be within ±50 ppm.

The TVP5151 also supports the use of a 27-MHz oscillator or clock source via connections to either the
XTAL1/OSC or AVID_CLK_IN pins. 1.8-V logic levels must be used when connecting a clock source to
the XTAL1/OSC pin of the TVP5151. Clock sources with 3.3-V output levels are supported by the
AVID/CLK_IN pin, but only when jumper J2 is configured for 3.3-V I/O. Additionally, the XTAL1/OSC pin
must be tied to GND to activate AVID/CLK_IN clock functionality. The XTAL1/OSC pin can be grounded
by replacing C62 with a 0-Ω resistor.

Figure 3. PCB Crystal Footprint
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3 Software Installation

This section summarizes the steps for setup and operation of the TVP5151EVM. If TVP5151EVM software
has been previously installed on the PC, you will be prompted to first uninstall the previous version.

3.1 Uninstalling Previous Version

To uninstall a previous version of TVP5151EVM software:

1. Click Start > Control Panel > Add or Remove Programs; wait for the list to populate.
2. Find and select "TVP5151EVM Software".
3. Click the remove button.
4. When prompted with "Are you sure you want to remove the TVP5151EVM Software from your

computer?", click Yes.

3.2 TVP5151EVM Software Installation

The TVP5151EVM Software package includes the Windows Control Center (VCC) application, device
initialization files, and documentation. This must be installed from the enclosed CD-ROM onto the PC that
will be used to control the TVP5151EVM via the PC USB port.

To install the software:

1. Insert the CD-ROM into the computer that will emulate the I2C bus via the USB port.
2. Run SETUP.EXE to install TVP5151EVM software and documentation.
3. Click Next at all prompts and click Finish to complete the installation process (see Figure 4 through

Figure 7).

Figure 4. TVP5151EVM Software Setup Wizard
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Figure 5. Select Installation Folder

Figure 6. Confirm Installation
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Figure 7. Installation Complete

Documentation and a shortcut to the TVP5151EVM VCC application are installed in the Windows Start
menu at:

Start > All Programs > TVP5151EVM > TVP5151EVM User Guide
Start > All Programs > TVP5151EVM > TVP5151EVM Software
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4 Hardware Setup

Figure 8 shows a typical TVP5151EVM setup used for evaluation.

Required Equipment

• TVP5151EVM
• NTSC or PAL composite video source such as a test generator or DVD
• Composite video cable
• USB cable
• YPbPr component video cable
• NTSC or PAL monitor with YPbPr component input
• Host PC with TVP5151EVM software installed

To prepare the EVM for evaluation, connect the following:

• USB cable from the host PC to the TVP5151EVM
• Analog composite video source to CH1 of the TVP5151EVM
• Analog component video output to an NTSC or PAL compatible monitor.

Figure 8. Typical Hardware Setup
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5 VCC Operation

This section describes operation of the TVP5151EVM VCC6 software.

5.1 Getting Started

After software installation (see Section 3) and hardware configuration (see Section 4) have been
completed, VCC may be started for evaluation of the TVP5151EVM.

5.2 Starting the VCC Application Program

The VCC6 (Windows™ Video Control Center) application program must have been previously installed on
the PC. Run VCC6 from the Windows Start Menu:

Start > Programs > TVP5151EVM > TVP5151EVM Software

5.3 VCC6 Configuration Dialog Box

The VCC Configuration dialog box, as shown in Figure 9, should now be visible. All settings from this
dialog box are stored in the Windows registry and are restored the next time the program is started. After
initial installation, VID_DEC should be set to TVP5151 and the THS8200 selected for DAC output.

The I2C slave addresses for each device must match the I2C slave address configured on the
TVP5151EVM. This TVP5151EVM is configured by the factory to use I2C address B8h for the TVP5151
and 40h for the THS8200.

It is important to select the correct specific device type. TVP5151 and THS8200 must be selected for the
TVP5151EVM.

Figure 9. VCC Configuration Dialog

Click on OK to proceed and begin USB I2C communication with the selected devices.
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5.4 USB I2C System Test

If a message occurs indicating that the USB device was not found (see Figure 10), disconnect the USB
cable, wait three seconds, reconnect the USB cable, and click Continue.

Figure 10. USB Error

If the USB device is still not found, see Section 6. If the USB link is functioning properly the Real-Time
Polling dialog box shown in Figure 11 appears.

5.5 Real-Time Polling

If the USB link is functioning properly, the Real-Time Polling dialog box in Figure 11 appears. When
real-time polling is enabled, VCC monitors the composite input format and automatically programs the
THS8200 when the input format changes.

Figure 11. Real-Time Polling

When enabled, real-time polling provides polling functions that continuously execute in the background.
When TVP5151 detects a change in the input video standard, it automatically switches to operation in the
detected standard (which includes all necessary I2C register initialization) for proper decoding of the input
video. To enable auto-switch on the TVP5151, the Set Video Standard register must be set to auto-switch
mode (register 0x28 = 0x00).

If the VCC auto-switch polling function is enabled, the detected video standard status from the TVP5151 is
polled until a change in the input video standard is detected. When a change is detected, the THS8200 is
reprogrammed as needed for the detected standard. Using this feature, the video source can change its
video standard and the system displays using the new standard without user intervention.

To enable auto-switch polling (recommended), the video-standard auto-switch polling function must be
enabled in the real-time polling dialog (see Figure 11). The real-time polling dialog can also be accessed
when VCC is running by clicking Real-Time Polling in the Tools menu.

Click on OK to proceed with Real-Time Polling enabled.
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5.6 Main Menu

After closing the real-time polling dialog, the Main Menu is displayed as shown in Figure 12. The menus,
which are used to operate VCC, are File, Edit, Tools, Window, and Help. The File menu’s only function is
Exit, which terminates the program. Table 3 is a summary of the main menu contents.

Figure 12. Main Menu

Table 3. Main Menu Summary

Menu Contents

File Exit VCC6

Edit Register Map Editor

Property Sheets

Tools System Initialization

Real-time Polling

USB/LPT I2C Options

Window Allows selection of the active window. Multiple windows can be open at the same time.
Initially the Window menu is empty.

Help About VCC

5.7 System Initialization

Clicking System Initialization in the Tools menu displays the dialog shown in Figure 13. This provides the
means for initializing the video decoder and/or video encoder for a particular video mode. The details of
the initialization are contained in the command file (with a CMD file extension).

The command file is opened using the Browse... button. Once the command file is opened, a text list
displays descriptions of the individual "data sets" contained within the command file.

Click once on the desired data set description to select it. Click the Program Device(s) Using Selected
Dataset button to run the selected data set, which loads the devices via the I2C bus. When the device
initialization has completed, the status indicator reads Ready.

NOTE: If Ready does not display, then the devices are not initialized and the I2C bus is not
communicating. See Section 6 for a solution.

Click the OK button to close the dialog box.
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Figure 13. System Initialization

5.8 Command Files

The command file is a text file which can be generated using any common editor; however, it must be
saved as plain text. Command files are especially useful for testing and comparing various changes in the
device setup.

A default command file, which should contain most of the desired setups, has been installed with the EVM
software. After installation, when the system initialization tool is opened, the default command file is
selected. This command file is located at:

C:\Program Files\Texas Instruments\TVP5151EVM\Initialization\TVP5151EVM_Setup.cmd

A command file can contain up to 250 data sets. A data set is a set of register settings to initialize the
video decoder and/or video encoder for a particular video mode. Each data set includes a description that
is displayed in one row of the dataset descriptions list. The register settings may be located in the
command file itself and/or may be stored in separate include file(s) (with an INC file extension) and be
included into the command file using the INCLUDE statement.

5.8.1 Example Command File

An example of one data set within a command file is shown in Figure 14. Each command file may contain
individual write to register (WR_REG) commands or include these commands from a separate INC file or
both. The purpose of the INCLUDE feature is to avoid repeating a long list of register settings many times
in a command file and having to maintain that list.

Command File Syntax
1. The comment indicator is the double-slash "//".
2. The command file is not case-sensitive and ignores all white-space characters.
3. All numbers can be entered as hexadecimal (beginning with 0x) or as decimal.
4. Every data set in a command file begins with BEGIN_DATASET and ends with END_DATASET. The

maximum number of data sets is 250.
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5. The data set text description is entered between double quotes using the DATASET_NAME command.
The enclosed text can be up to 128 characters in length. This text appears in the system initialization
dialog when the command file is opened.

6. The INCLUDE command inserts the contents of an include file (with an INC file extension) in-line in
place of the INCLUDE command. Therefore, the include file should not contain the BEGIN_DATASET,
END_DATASET, and DATASET_NAME commands.

7. The write to register command is written as follows:
WR_REG, <DeviceFamily>, <Number of data bytes (N)>, <subaddress>, <Data1>,…,<DataN>
or
WR_REG,<Literal slave address>,<Number of data bytes (N)>,<subaddress>, <Data1>,…,<DataN>

8. The valid device family mnemonics are:
VID_DEC for the video decoders
THS8200 for the THS8200 device

9. VCC6 translates the device family mnemonic to the slave address that was selected on the VCC6
configuration dialog upon program startup. This eliminates having to edit command files if the alternate
slave address must be used.

10. If the literal slave address method is used, the slave address entered is used directly.
11. A delay may be inserted between commands using the WAIT command:

WAIT,<# milliseconds>

NOTE: All included files must be located in the same directory as the command (CMD) file.

BEGIN_DATASET

DATASET_NAME, "NTSC in, 480i60 YPbPr out"
//TVP5151
WR_REG,VID_DEC,1,0x03,0x69 // GPCL HIGH, YUV output enable
WR_REG,VID_DEC,1,0x07,0x20 // Pestal control on

//THS8200
WR_REG,THS8200,0x01,0x03,0x11 // chip_ctl
WR_REG,THS8200,0x01,0x1C,0x04 // dman_cntl
WR_REG,THS8200,0x01,0x1D,0x00 // dtg_y_sync1
WR_REG,THS8200,0x01,0x1E,0x49 // dtg_y_sync2
WR_REG,THS8200,0x01,0x1F,0x00 // dtg_y_sync3
WR_REG,THS8200,0x01,0x20,0x00 // dtg_cbcr_sync1
WR_REG,THS8200,0x01,0x21,0x00 // dtg_cbcr_sync2
WR_REG,THS8200,0x01,0x22,0x00 // dtg_cbcr_sync3
WR_REG,THS8200,0x01,0x23,0x22 // dtg_y_sync_upper
WR_REG,THS8200,0x01,0x24,0x2A // dtg_cbcr_sync_upper
WR_REG,THS8200,0x01,0x25,0x3E // dtg_spec_a
WR_REG,THS8200,0x01,0x26,0x14 // dtg_spec_b
WR_REG,THS8200,0x01,0x27,0x1E // dtg_spec_c
WR_REG,THS8200,0x01,0x28,0x79 // dtg_spec_d
WR_REG,THS8200,0x01,0x29,0x00 // dtg_spec_d1
WR_REG,THS8200,0x01,0x2A,0x00 // dtg_spec_e
WR_REG,THS8200,0x01,0x2B,0x01 // dtg_spec_h_msb
WR_REG,THS8200,0x01,0x2C,0x6B // dtg_spec_h_lsb
WR_REG,THS8200,0x01,0x2D,0x03 // dtg_spec_i_msb
WR_REG,THS8200,0x01,0x2E,0x1B // dtg_spec_i_lsb
WR_REG,THS8200,0x01,0x2F,0x11 // dtg_spec_k_lsb
WR_REG,THS8200,0x01,0x30,0x00 // dtg_spec_k_msb
WR_REG,THS8200,0x01,0x31,0x0A // dtg_spec_k1
WR_REG,THS8200,0x01,0x32,0xAD // dtg_speg_g_lsb
WR_REG,THS8200,0x01,0x33,0x01 // dtg_speg_g_msb
WR_REG,THS8200,0x01,0x34,0x03 // dtg_total_pixel_msb
WR_REG,THS8200,0x01,0x35,0x5A // dtg_total_pixel_lsb
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WR_REG,THS8200,0x01,0x36,0x00 // dtg_linecnt_msb
WR_REG,THS8200,0x01,0x37,0x01 // dtg_linecnt_lsb
WR_REG,THS8200,0x01,0x38,0x84 // dtg_mode
WR_REG,THS8200,0x01,0x39,0x21 // dtg_frame_field_msb
WR_REG,THS8200,0x01,0x3A,0x0D // dtg_frame_size_lsb
WR_REG,THS8200,0x01,0x3B,0x07 // dtg_field_size_lsb
WR_REG,THS8200,0x01,0x3C,0x80 // dtg_vesa_cbar_size
WR_REG,THS8200,0x01,0x41,0x40 // csm_clip_gy_low
WR_REG,THS8200,0x01,0x42,0x40 // csm_clip_bcb_low
WR_REG,THS8200,0x01,0x43,0x40 // csm_clip_rcr_low
WR_REG,THS8200,0x01,0x44,0x53 // csm_clip_gy_high
WR_REG,THS8200,0x01,0x45,0x3F // csm_clip_bcb_high
WR_REG,THS8200,0x01,0x46,0x3F // csm_clip_rcr_high
WR_REG,THS8200,0x01,0x47,0x40 // csm_shift_gy
WR_REG,THS8200,0x01,0x48,0x40 // csm_shift_bcb
WR_REG,THS8200,0x01,0x49,0x40 // csm_shift_rcr
WR_REG,THS8200,0x01,0x4A,0xFC // csm_mult_gy_msb
WR_REG,THS8200,0x01,0x4B,0x44 // csm_mult_bcb_rcr_msb
WR_REG,THS8200,0x01,0x4C,0xAC // csm_mult_gy_lsb
WR_REG,THS8200,0x01,0x4D,0x91 // csm_mult_bcb_lsb
WR_REG,THS8200,0x01,0x4E,0x91 // csm_mult_rcr_lsb
WR_REG,THS8200,0x01,0x4F,0xFF // csm_mode
WR_REG,THS8200,0x01,0x70,0x40 // dtg_hlength_lsb
WR_REG,THS8200,0x01,0x71,0x03 // dtg_hdly_msb
WR_REG,THS8200,0x01,0x72,0x59 // dtg_hdly_lsb
WR_REG,THS8200,0x01,0x73,0x04 // dtg_vlength_lsb
WR_REG,THS8200,0x01,0x74,0x00 // dtg_vdly_msb
WR_REG,THS8200,0x01,0x75,0x04 // dtg_vdly_lsb
WR_REG,THS8200,0x01,0x76,0x04 // dtg_vlength2_lsb
WR_REG,THS8200,0x01,0x77,0x01 // dtg_vdly2_msb
WR_REG,THS8200,0x01,0x78,0x0B // dtg_vdly2_lsb
WR_REG,THS8200,0x01,0x79,0x00 // dtg_hs_in_dly_msb
WR_REG,THS8200,0x01,0x7A,0x44 // dtg_hs_in_dly_lsb
WR_REG,THS8200,0x01,0x7B,0x00 // dtg_vs_in_dly_msb
WR_REG,THS8200,0x01,0x7C,0x00 // dtg_vs_in_dly_lsb
WR_REG,THS8200,0x01,0x82,0x27 // pol_cntl

END_DATASET

Figure 14. Example CMD File

5.8.2 Adding a Custom Data Set to a CMD File

To create a custom dataset, program the EVM via the system initialization tool using the factory-supplied
command file. Through the property sheets tool or I2C Register Map Editor you can then customize the
device register settings to suit your needs and save the settings as a new dataset. To save your custom
settings:

1. Open the System Initialization dialog via the Tools menu.
2. Click Append Current Device Settings to Command File. A dialog requesting a description on the new

data set appears.
3. Optionally, click the dropdown box and select one of the existing descriptions.
4. Modify the description text or type a new description.
5. Click OK. All non-default register values are read from the TVP5151 and THS8200 and are appended

to the current command file as an additional data set.
6. Select the custom data set and press the Program button to send.

19SLEU106–November 2009 TVP5151 Evaluation Module
Submit Documentation Feedback

Copyright © 2009, Texas Instruments Incorporated

http://www.go-dsp.com/forms/techdoc/doc_feedback.htm?litnum=SLEU106


VCC Operation www.ti.com

5.9 Register Editing

The next sections describe the two available modes of register editing: register map editors and property
sheets. Each of these functions can be selected from the Edit menu.

5.9.1 TVP5151 Register Map Editor

The register map editor, as shown in Figure 15, allows the display and editing of the entire used register
space of the device within a simple scrolling text box. To open this, click on Edit Register Map in the Edit
menu and click on the device type to edit. Table 4 describes how to use each of the controls in the
register map editor.

Figure 15. TVP5151 Register Map Editor

Table 4. Register Map Editor Controls

Control Definition

Register Window Scrolling text box that displays the address and data for the I2C registers that are defined for the device.

This contains the I2C subaddress that is accessed using the Write and Read buttons. Clicking on a row
selects an address, which then appears in the address edit box.
NOTE: After clicking on a row, the Data Edit Box contains the data that was in the register window. This data
may not correspond to the actual data in the device (until Read or Read All is clicked).Address Edit Box The address up/down arrows are used to jump to the next/previous subaddress that is defined for the
device.
NOTE: If an address is not defined for the device, it can still be accessed by typing the subaddress in the
Address Edit Box.

This contains the data to be written to or read from the I2C subaddress.Data Edit Box The data up/down arrows increases / decreases the data value by 1.

Writes the byte in the Data Edit Box to the address in the Address Edit box.Write Button The I2C register is written to whether or not the data is different from the last time the register was read.

Read Button Reads the data from the address in the Address Edit Box into the Data Edit box and the register window.

Read All Button Reads all defined readable registers from the device and updates the register window.

Hex Button Displays all values in the register window and address and data edit boxes in hexadecimal format.

Dec Button Displays all values in the register window and address and data edit boxes in decimal format.

Closes the dialog.
Close Button NOTE: Multiple edit register map windows can be open at the same time (one for each device). Use the

Window menu to navigate.

Causes subsequent write or read operations to be performed N times. N is entered as a decimal number
Loop Count from 1 to 999.

Opens the indirect register editor of the TVP5151.
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NOTE: To save current register settings to a file, check the Histogram Enable check box and click
Read All. Click Show to view the saved file.

5.9.2 THS8200 Register Map Editor

The THS8200 register editor, as shown in Figure 16, allows the display and editing of the THS8200
registers. This editor works like the TVP5151 editor.

To open this, click on Edit Register Map in the Edit menu and click on THS8200.

Figure 16. THS8200 Register Map Editor

5.9.3 Generic I2C Register Editor

The Generic I2C Editor, as shown in Figure 17, allows the display and editing of any device on the I2C
bus. This editor works like the Register Map Editor, except that the I2C slave address must be entered and
the Read All button is disabled.

To open this, click on Edit Register Map in the Edit menu and then click on Generic I2C.

The Generic I2C Editor can be used to communicate with other devices that can be connected to
TVP5151EVM I2C bus.
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Figure 17. Generic I2C Register Map Editor

5.10 Property Sheets

The property sheets represent the register data in a user-friendly format. The data is organized by
function, with each function having its own page and being selectable via tabs at the top (see Figure 18).

To open this, click on Edit Property Sheets in the Edit menu and select the device type to edit.

When the property sheet function is started, or whenever you tab to a different page, all readable registers
in the device are read from hardware to initialize the dialog pages. Values on the page are changed by
manipulating the various dialog controls as described in Table 5.

There are OK, Cancel, and Apply buttons at the bottom of each property page. These are explained in
Table 6.

Figure 18. TVP5151 Analog Video Property Sheet
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Table 5. Use of Property Sheet Controls

Dialog Control What Do I Do With It? When is Hardware Updated?

Read-only edit box Read status information N/A

Check box Toggle a single bit After Apply

Dropdown list Select from a text list After Apply

Edit box Type a number After Apply

Up/Down arrows: ImmediatelyEdit box with up/down arrows Use up/down arrows or type a number Type a number: After Apply

Slider Slide a lever Immediately

Push button Initiate an action Immediately

Table 6. Property Sheet Button Controls

Button DefinitionControl

Writes to all writeable registers whose data has changed. A register is flagged as changed if the value to be
written is different from the value last read from that address.OK
Closes the dialog.

Causes all changes made to the property page since the last Apply to be discarded. Changes made to dialog
controls with immediate hardware update are not discarded, since they have already been changed in hardware.

Cancel Does not write to hardware.

Closes the dialog.

Writes to all writeable registers whose data has changed. A register is flagged as changed if the value to beApply written is different from the value last read from that address.

To enable multi-standard auto switching, select multi-standard mode and uncheck the formats that you
want to include (see Figure 19).

Figure 19. TVP5151 Video Format Property Sheet

Vertical lock, horizontal lock, color lock, and the detected video standard can all be observed with the
TVP5151 Video Decoder Status Property Sheet (see Figure 20).
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Figure 20. TVP5151 Video Decoder Status Property Sheet

The THS8200 Input Controls Property Sheet can be used to check the output format being received from
the TVP5151 (see Figure 21). Pixel Count and Line Count are the total pixels per line and total lines per
frame received from the TVP5151. Clicking on the RESET button followed by Read All ensures a current
Format Detection Status reading. The THS8200 Digital Input Format must be left set to ITU-R BT.656 and
the Timing Source must be left set to Embedded for proper operation.

Figure 21. THS8200 Input Controls Property Sheet
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5.10.1 Property Sheet Refresh

The TVP5151 property sheets were designed so that the data displayed is always current. Certain actions
cause the entire register map to be read from the device and to update the property sheets. This happens
when:

• Property sheets are initially opened.
• When tabbing from one page to another.
• When Read All is clicked.
• When making the Property Sheets window the active window (by clicking on it).
• When making a register map editor window the active window.

5.10.2 Auto-Update When Activating Windows

When you open both the property sheets and the register map editor at the same time, changes made to
the property sheets (and applied) are updated in the register map window as soon as the register map
window is clicked on. It also works the other way; changes made in the register map editor are updated in
the property sheets as soon as the property sheets window is clicked on.

5.10.3 Property Page Auto Update

When the video decoder Video Format page is showing and the property sheets window is the active
window and the Auto Update button on that page is enabled (default), the TVP5151 register map is read
continuously and the status controls on that page are continuously updated.
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6 Troubleshooting the TVP5151EVM

This section discusses ways to troubleshoot the TVP5151EVM.

6.1 Troubleshooting Guide

If you are experiencing problems with the TVP5151EVM hardware or the VCC6 software, see Table 7 for
available solutions.

Table 7. Troubleshooting Guide

Symptom Cause Solution

Go to Edit>Property Sheets>TVP5151, input selection/AGC page, selectWrong video input is selected. the correct video input(s), and click Apply. (CH1 is selected by default.)

Source is connected to the wrong Connect source to the correct input connector.input connector.

YCbCr outputs or clock output is Go to Edit>Property Sheets>TVP5151, output page, check enable YCbCr
disabled. outputs and enable clock outputs, and click Apply.

Component output cable improperlyBlank screen Check cable with direct video connection to the monitor.connected to the monitor

The monitor being used does not Verify cables and monitor operation by connecting the signal sourcesupport the video format being directly to the display.used.

Auto-switch not functioning See Auto-switch issues below.

Damaged RCA connector or PCB Check signal traces to and from RCA connectors for damage.trace

Incorrect video format selected. See Auto-switch issues below.
No color

Color burst input issue Check composite signal input levels.

Go to Edit>Property Sheets>TVP5151, output page, set the YCbCr outputScreen colors are only magenta Wrong YCbCr output format. format to 8-bit 4:2:2 YCbCr w/ITU-R BT.656 embedded sync mode andand green. click Apply. Check THS8200 Input Format setting.

Auto-switch masks are not set Go to Edit>Property Sheets>TVP5151, mode selection, uncheck all
correctly. standards to be included in auto-switch processing, and click Apply.Video standard auto-switch does

not work on the video decoder side. Video decoder is not in auto-switch Go to Edit>Property Sheets>TVP5151, mode selection page, set the
mode. drop-down box to multi-standard and click Apply.

Video standard auto-switch does Auto-switch polling is not enabled. Click real-time polling in the Tools menu. Click Enable All and OK.not work on the video encoder side.

TVP5151 I2C slave address is Make sure the TVP5151 I2C slave address selected at start-up is correct.wrong.

THS8200 I2C slave address is Make sure the THS8200 I2C slave address selected at start-up is correct.wrong.

USB cable is not connected from Connect cable and make sure the USB Link LED indicator is lit.TVP5151EVM to the host PC.
USB: I2C error code 1 EVM has been modified for use Make sure that the 5V LED indicator is lit indicating the presence of 5Vwith a separate 5V power supply power.that is not connected.

TVP5151 was placed in Place J7 jumper in Normal position.power-down mode.

EVM was configured for an external
Reinstall 0-Ω resistors R131 and R132.

I2C master.

J9 jumper not installed. USB cable Install jumper and disconnect/reconnect USB cable. USB Link LED shouldUSB: Device not found is not connected. be on.

USB: Invalid response code receive Multiple instances of VCC are Close all but one VCC instance.form device running.

Multiple instances of VCC areErratic or inconsistent I2C register Close all but one VCC instance.running.read back.

Attach USB cable and exit or use the Windows Task Manager to endCan't exit VCC USB cable has been removed. VCC.

YPbPr output levels are distorted Improper video termination at the Install 75-Ω termination resistor at the oscilloscope input.and too high. oscilloscope.

Bad cable or damaged RCA Check cable with direct connect to the monitorconnectorNo red or blue color displayed
Broken PCB trace Check signal path and traces connecting to the YPbPr connector.
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6.2 Resolving I2C Communication Problems

When VCC is started, and the VCC Configuration dialog box is closed with OK, a USB I2C functionality
test is performed. If the I2C system test fails, a dialog box like Figure 22 appears. This figure reports that
an I2C read from the TVP5151 failed, using slave address 0xBA, subaddress 0x00.

Similarly, a dialog box like Figure 23 appears if there are I2C communication problems with the THS8200.
If either of these dialog boxes appears, click on Exit Program. Restart VCC and ensure that the I2C
addresses are set to the correct address. The hardware default addresses are 0xB8 and 0x40 for the
TVP5151 and THS8200, respectively.

Figure 22. TVP5151 I2C Error Report

Figure 23. THS8200 I2C Error Report

If a dialog box similar to Figure 24 appears, check the USB cable connection and the USB Link LED on
the TVP5151EVM. The USB Link LED is lit if a valid USB link is established. Press the Continue button
after the USB link is established.

Figure 24. USB Link Error
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Figure 28. Schematic - USB/I2C
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